ArchLabs i3-Gaps showing only wallpaper and cursor

Recently, I’ve tried installing plasma package myself (i’m using openbox and i3wm). everything was working then, but actually, I didn’t like plasma/kde at all and decided to remove it using “sudo pacman -R plasma”. after that, when I tried to start my i3wm, it was showing just the wallpaper and the cursor, nothing else worked. so I opened CLI using ctrl+alt+f2, logged in and returned to GUI using ctrl+alt+f7. it worked. but actually, the problem is that I have to do everytime this method to get on my i3wm. All I want is just getting rid of this issue. I’ll be glad if I could get any help from you.

Hello @meapx!

This may be helpful:

actually, I’m using LightDM. Is that a problem with it?

Have you checked the status of the service?

$ systemctl status lightdm.service 

● lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2019-01-03 15:27:13 EET; 18min ago
Docs: man:lightdm(1)
Main PID: 472 (lightdm)
Tasks: 4 (limit: 4915)
Memory: 52.9M
CGroup: /system.slice/lightdm.service
├─472 /usr/bin/lightdm
└─478 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Jan 03 15:27:13 xenon systemd[1]: Starting Light Display Manager…
Jan 03 15:27:13 xenon systemd[1]: Started Light Display Manager.
Jan 03 15:27:16 xenon lightdm[524]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Jan 03 15:37:45 xenon lightdm[573]: pam_unix(lightdm:session): session opened for user xenon by (uid=0)

See what other services are running:

systemctl list-units

Something may have been left behind when you removed plasma. Did you reboot after uninstalling plasma?

Were you using sddm with KDE or did you stay with LightDM?

I rebooted after that and no, I wasn’t using sddm with KDE.

so, nobody knows how to solve it? :confused:

Did you try to remove orphan packages ?

And did you try to disable lightdm? Like, login from a tty and then xinit does the trick ?

1 Like

^ This

I suspect something got left behind when you uninstalled.

Quick search indicates getting KDE uninstalled is a bit difficult; appears you need to use a more aggressive command with pacman which can potentially remove needed packages.

Search the Arch forum / wiki for removing KDE.

Using -R alone only removes the package given, all dependancies will be left untouched, use -Rns to really remove something.


pacman -S plasma  # so we can properly remove it

pacman -Rns plasma

Reboot after and let us know if you still have problems.

tried that, but the same issue.
also, I’ve tried disable LDM using

$ systemctl disable lightdm.service

but it doesn’t solve it. I’ve used xinit from tty and it logged in a very strange session, with a white weird terminal. just don’t know how to change between sessions from tty.

read this thread switching between i3 and openbox without lightdm