ArchLabs i3 experience?

Hi,

I am absolutely loving AL - thank you so much
I installed it just with open box as I already had EOS and Archbang i3
Now I would like to drop EOS and install i3(wm I dont personally like gaps) on AL
I am pretty sure I Know how to do that and have config and i3blocks etc to use/modify etc but …

How can I get the ‘AL experience’ as in that which I would have got if I had chosen i3 on installation
I guess there are custom config, i3 blocks etc for AL?

On a similar vein - is there a version that is considered ‘flagship’ AL? Is Openbox the ‘main’ one, with the most customisation?

The only gripe I have against AL is that it is obviously so easy to customize but its all so slickly done and to my taste that I have nothing to do :rofl:

3 Likes

You’ll find them in /etc/skel/.

4 Likes

Thanks!

2 Likes

Not any more. The original version of AL shipped with a customized openbox desktop. The openbox and tint2 files are still in /etc/skel, but the user has to choose to install openbox.

As far as i3 goes, the original AL i3 configuration was i3-gaps with polybar. Since polybar tends to break when some json files get updated, it was dropped. I don’t think the i3-gaps configuration is still installed in /etc/skel.

5 Likes

AL does offer an excellent in-house configuration of Sway (thanks @nwg ) if you want to go that route instead of i3. Those configurations are in /etc/skel, and I believe all the needed packages have been updated.

4 Likes

New skel files for sway should be available soon on the testing repo. Current configuration does not reflect latest changes, so I suggest to wait a minute.

2 Likes

Thanks for trying it out and glad to hear you like it.

I would say i3, openbox, sway, and dk are all ‘flagship’ sessions for AL, they’re the ones we’ve invested the most time in and have the most cohesive (as if that’s even possible) offerings we have. Now which is best for you is really a matter of taste. The others weren’t ignored but without experience we try to offer them up as stock as possible while still being usable, we take more liberty with the above four.

Install archlabs-i3-skel then you’ll find the files in /etc/skel/.config/i3 as mentioned above. You can copy these and remove a few things related to the -gaps version of i3, or just change one line

gaps inner 8
# to
gaps inner 0
3 Likes

This.

In my mind the wm’s listed by Nate are the more inline wm’s with the AL ethic (if one exists, maybe “ethic” isn’t quite the right word).

2 Likes

ethos?

Thanks

is that archlabs-skel-i3-gaps?

And what does installing that do? does it update the AL .config etc in /etc/skel /.config/i3?
It doesnt seem to put AL .config in ~/.congif/i3

I have all the stuff to cut and paste accross from my EOS-i3 and Archbang (when Mr Green had i3 in it) .configs so I can have some fun playing around now

I chose Openbox for AL initially as I already had 13 on my EOS partition, but I have just removed that and am fully AL so will put i3 on that too

As a very sinister person I think that the AL i3 .config should have the following in it (please!) as there are a lot of us around:


# Left-handed mouse
#exec xmodmap -e "pointer = 3 2 1"

Also, if I change my .xinitrc to exec i3 then if I logout of AL and run exec openbox-session it boots into AL OB, but the ‘vice versa’ doesnt work - exec i3 (after changing .xinitrc to exec openbox-session) after loging out of AL OB doesnt start i3 session but goes back into OB.

I love learning, which is good as I have an awful lot of it to do :rofl:

Yes my bad, I had it wrong above.

No, it’s up to the user or installer to copy the defaults. I’ll add the left hand mouse to our configs.

Can you please post the full xinitrc for us? Impossible to know what’s going on without seeing that first.

3 Likes

Thanks @natemaia

My .xinitrc is as the end of this post

If I use it as it is shown below then it starts in i3 fine, and when I logout of the i3 session and run exec openbox-session I just get into an i3 session (Edit: I was wrong before)

And, if I comment out exec i3 and un-comment exec openbox-session in the .xinitrc I can start up into openbox fine but when I log out of the OB session and run exec i3 I just get into another Openbox session.

Obviously I have not understood something correctly.

I am trying to work out a way to switch between i3 and openbox without editiing .xinitrc each time, via starting the session from the CLI

(Related but not same ‘problem’: I have read that I can run two DE at the same time via TTY, but I dont know how to ‘start’ the other DE in the CLI of the TTY)

#!/bin/sh

# this file is run when calling startx

# default arch init scripts
if [ -d /etc/X11/xinit/xinitrc.d ]; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh; do
        [ -x "$f" ] && . "$f"
    done
fi

# user init scripts and settings
[ -r /etc/X11/xinit/.Xmodmap ] && xmodmap /etc/X11/xinit/.Xmodmap
[ -r ~/.Xmodmap ] && xmodmap ~/.Xmodmap
[ -r ~/.Xresources ] && xrdb -merge ~/.Xresources
[ -r ~/.xprofile ] && . ~/.xprofile

# launch the session, commands below this line will be ignored
#exec openbox-session
exec i3

My experience thus far on ArchLabs i3 has been…inspiring… :hugs:

2 Likes

You need to set up your .xinitrc to handle multiple window managers.

ArchWiki xinit

In the .xinitrc section, scroll down to the multiple window manager section.

4 Likes

Just use ly

3 Likes

I use tbsm only because I have two system…

I am going to have a look at the solution suggested by @PackRat first as a learning experience for me.
Thanks for other alternatives replies

I tried following the Arch Wiki example

I have no idea on the syntax (or even what language it is) so I guessed and used the below, but no luck (no permission was one error)

It didnt work on startup to try to start openbox, and neither did from the cli typing xinit i3

No doubt I have guessed wrong!

#!/bin/sh

# this file is run when calling startx

# default arch init scripts
if [ -d /etc/X11/xinit/xinitrc.d ]; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh; do
        [ -x "$f" ] && . "$f"
    done
fi

# user init scripts and settings
[ -r /etc/X11/xinit/.Xmodmap ] && xmodmap /etc/X11/xinit/.Xmodmap
[ -r ~/.Xmodmap ] && xmodmap ~/.Xmodmap
[ -r ~/.Xresources ] && xrdb -merge ~/.Xresources
[ -r ~/.xprofile ] && . ~/.xprofile

# launch the session, commands below this line will be ignored
#exec openbox-session
#exec i3

# Here Openbox is kept as default
session=${1:-openbox-session}

case $session in
    i3           ) exec i3;;
esac

Although still very interested to know where I was going wrong in the above - The Arch Wiki ‘overide .xinitrc’ section gave me a solution that works really well for me

I just reverted to my exec openbox-session in my .xinitrc and when I want to enter i3 I logout of openbox and run startx /usr/bin/i3 to start i3
:smiley:

you need an “openbox-session” entry in the list of window managers. Here’s my current .xinitrc for multiple window managers.

# Window manager for X session
# to start a different WM, set session="WM" below, or in console run:
# startx ~/.xinitrc WM

# session to run if none passed as first arg ($1)
session="${1:-dkwm}"

# set environment wm for use in scripts
export WM="$session"

# do NOT put commands below the exec lines
case $session in
    dkwm)       exec dk ;;
    openbox)    exec openbox-session ;;
    i3)         exec i3 ;;
    *)          exec "$session" # Unknown, try running it
esac

exit 0 ;
4 Likes

Now this is something different, I think I’m going to use it. CHEERS! :))

Handy information Thanks.