Archlabs doesn-t boot after installation on Vbox

#1

I succeded in installing Archlabs (latest build) in both VBox 6 and VMware6 (I got the welcome message), but when I reboot I get this and cannot continue:

What does it mean? Something went wrong, perhaps?

I am trying to install it on a recent DELL Precision.

Thanks!

0 Likes

#2

What window manager or desktop env did you choose and installed ?
Did you opt for display-manager or xinit ?
For display manager type

systemctl is-enabled lightdm.service

if not then

sudo systemctl enable lightdm && sudo systemctl start lghtdm

and for xinit just type

startx

1 Like

#3

I cannot even boot into Archlabs. I’m simply stuck at the screen showed in my previous message, which appears after I am requested to input my name and password.

I carefully followed the instructions found in several YouTube videos, and this happens with bot VBox and VMware.

0 Likes

#4

I don’t know if this helps, but the very last character shown in the terminal-like screen above is “%”.

0 Likes

#5

You do not answer my questions … if you need help you should. this “%” means you are connected to your session. Did you tried

startx

1 Like

#6

Try
./xinitrc start i3
(or openbox, or whatever you use)
That’s how I did for my first archlabs, now for this one I use startx.
If it doesn’t work can you do
cat .xinitrc && cat .xsessionrc
and show us?

1 Like

#7

This is clearly not the case, in the image above you have a booted system that appears to be installed, and are mistaking no graphical interface for not booted.

I think going for a more beginner friendly distro is honestly a better option for now, don’t take this the wrong way, but you will have issues.

Feel free to use it if you really want to, no-one is going to stop you, but you won’t have a good time and “issues” like this will be ongoing.


With all that out of the way, get used to using a terminal constantly.

Post me the output of the following

pacman -Qs lightdm xorg-xinit

cat ~/.xinitrc

ls /etc/systemd/system

And tell me what choice you made during install (I only care about which login session and packages you chose, partitioning and other choices aren’t important in this case)

Cheers

0 Likes

#8

I can also confirm it does indeed boot to a graphical session and you likely didn’t pick one during the install.

If you tell me which you want (openbox, i3, xfce, plasma, etc…) I can post some commands to run that will install and setup so after reboot you reach a graphical interface.

0 Likes

#9

My bad, I apologize with everybody. I thought I had made the various selections correctly, but I didn’t select the desktop actually (I didn’t actually use the spacebar to make selections).

Now Archlabs is up and running. I am a Linux beginner as you already understood, but not completely illiterate. In another PC I’ve got Manjaro in dual boot with Windows and it’s working well.

Thanks to all!

3 Likes