ArchLabs 2022.08.21 Release

It won’t, the repo’s no longer contain the required packages, might get lucky with certain DE’s that we didn’t have anything for but I suspect they’ll all fail.

no it uses exec which forks so you’re running a completely different executable

Run the current installer and install a small session like dk then in the “Run command” menu option use

pacman -S plasma kde-applications-meta powerdevil

Then once the install is done and you’re prompted with the various files to edit choose the “login” option, in the .xinitrc change

exec dk

# to

exec startplasma-x11

After reboot you can remove the dk packages and configs from your home

pacman -Rnsc dk archlabs-skel-dk archlabs-lemonbar
rm ~/.config/dk
2 Likes

The new iso will not boot for me is lightdm the default for dk in the live session.

No lightdm.

Should just auto login. If it fails to log into the xsession, it should just drop you to the command line and you can run the installer from there if you want.

You getting any kind of error message trying to boot?

1 Like

I get a no monitor connected error message, AHH does the live session use Grub?, I’ve seen the same error message with Grub.
I will hang onto the old ISO that has no live session I installed from that yesterday without any problems, I’ve had problems with other live arch ISO my old laptop only seems to work with syslinux for some reason, no big deal

Wont boot or won’t log into X?

Maybe unrelated, but on VirtualBox w/ 3D acceleration turned on the installer hangs on this screen:

1 Like

You could try removing /etc/X11/xorg.conf.d/40-touchpad.conf sometimes it causes issues with VMs and it’s included in the live session (a mistake in hindsight). I’m not sure that will fix it but it seems to be caught up on the configs so worth a shot.

Does it hang for good or eventually drop you back to console?

I’m stuck at this point forever.

Does Ctrl-c get you out?

Nope.

Right when you boot and it says with the “archlabs login: root (automatic login)” you can get out of it with Ctrl-c (don’t let X start) or you can edit the boot params in grub and add single to the end of the linux ... line.

I’ll probably install vbox and try it out but I suspect I won’t have the same issue.

This is a very minor issue. 3D acceleration in VM is only needed to run sway. Sway on VM sucks for other reasons.

1 Like

Thanks for the suggestions. I’ll look into polybar but not too keen on it, the status timers though is a very good point.

The borders can really be slimmed down, it’s probably worth tweaking depending on the resolution as 1px on 2160p (28") or 1080p (14") is barely visible. On lower DPI displays 1px is perfect.

Will not log into x, this morning it dropped me back to the command line


Yesterday it hung before it had time to drop into the command line, as I said my laptop’s quite old and only works if I use syslinux I seem to have a problem with grub no Idea while it always throws up the same error but it cannot be xorg as I did a clean install yesterday without any errors maybe its time to get a newer laptop but this one’s only 14 year’s old

I had a similar error on an old HP laptop. After you’re dropped out to the command line, you can try:

rm /etc/X11/xorg.conf.d/20-*

Then

startx

to see if that gets you to the live session.

4 Likes

Thanks I will give it a try this evening when I get home

Installed i3 on a spare drive. No choice since sway is gone. Auto login very broken. Escape xorg having a hissy fit. startx straight to session. Maybe I will try openbox. :man_shrugging:

See https://github.com/nwg-piotr/nwg-shell/discussions/17.

1 Like

Perhaps I shouldn’t include these by default?


@Kamu can you post the output from the following

ls /etc/X11/xorg.conf.d

lspci | grep 'VGA'

Can you elaborate on this? After it failed once running startx yourself worked? Do you have anything in /etc/X11/xorg.conf.d/

I repeated the log in a second time on reboot. Auto login should toss you into the session. It does not. Xorg complains…It will after some time drop to a prompt. At which point it will allow startx. After that it is all cool beans. :melting_face: