Archlabs 2021.05.02 installation error

hello everyone. i have been wanting to try out archlabs and as a noob its been giving me a harder time than i thought it would.

I cant seem to get past the initial installation. everytime i try to do just the most barebones configuration. i keep getting an error without an error message.

ive tried this on both a vm and on my laptops actual ssd through a flash drive

hi gregO, welcome to the forum! Sorry it starts out like that right now, but let’s see if someone comes up with a smart idea. I can, by chance, confirm your issue; I had the same last night when I tried to re-install AL. Hanfg on in there :wink:

ty peppe,

i was wondering if it had anything to do with that line that says:
sed: can’t read /mnt/etc/locale.gen: No such file or directory

i thought maybe it was looking for a local.gen when before that a symlink was created saying:
/mnt/etc/locale.conf → /mnt/etc/default/locale

so i tried changing the some lines in the installer command script from the iso. from everything that says local.gen to just local but the same error happens. lol i thought that would have been too easy.

Same package?

Have a look at this thread.

Looks like you can pause the installer, run that command to fix the issue, then restart the installer. Hopefully, it’s just the one package.


I would also add if you updated the installer before the installation attempt, guess that it was recommended or such from @natemaia if I do remember well.

Edit; I don t remember which thread sadly.

1 Like

from that thread it says i should arch-chroot /mnt and then go back to continue the installer. i just did but i got a bin/bash no such file or directory error

This sounds like a download issue due to arch mirrors, during install did you select countries for this?

Please try again but when prompted to select mirror countries just press Enter/Return, apologies for the issue and it’s currently being worked on to avoid issues like this in the future.



Great, I’ll check it soon in a VM and let you know the outcome. I did indeed specifically select a number of countries to use for mirrors (as I always do)

wow i didn’t expect an admin to notice my thread. I appreciate this a lot. i have pressed on enter when prompted for the mirror country presumably so that it automatically chooses the correct country for me. but the same issue happens.

the mirrors thing does sound right since when i download anything from pacman or try to upgrade the system with pacman -Syyu i keep getting these errors saying unrecognized archive format for the databases.

i still cant get it to work even though if i just press enter on the mirror countries prompt and i just now tried selecting all the countries same thing :frowning:

whats intersting is i tried pacman -Syyu while the installer is paused when i was prompted after the error and it started downloading something a “jack with extra/jack2” package. then it says it will download 500mb and install 20gigs worth of packages

then an error happens saying i dont have enough space.
pretty sure i gave this vm 40 gigs of space

ill try again with 60 gigs. see if that does anything. though i doubt it

Welcome to ArchLabs, @gregO.

I assume you were still in the live environment. You could type,

#df -h

to verify.

To start over, let’s try these steps,

  1. boot up the image
  2. configure network
  3. delete old pkg db files,
    #rm /var/lib/pacman/sync/*
  4. sync the databases,
    #pacman -Sy
  5. launch the installer to install.

hello chroot.
thanks for giving me time :smiley:
i tried the steps you gave.
after configuring the network, i tried rm /var/lib/pacman/sync/
but it said no such file or directory
so i did pacman -Sy
which synced it no problem.
i then continued with the installer but i was back the same error (the one without any error messages just saying
sed: can’t read /mnt/etc/locale.gen: No such file or directory)
i paused the installation and did
rm /var/lib/pacman/sync/
it said it was a directory so i did rm -f instead
then did pacman -Sy
continued but the same error happened :frowning:

now im starting to think the mirrors isn’t actually the problem.

when i said continued at the end there i meant continued with the installer.

Yup, invalid or corrupted packages no matter if I select no countries for mirrors, I also tried a few different countries a few times…


Rather than using the 2021.05.02 archlabs iso, you could instead download the latest archlinux iso, use iwctl to connect to internet if using wifi (see iwd - ArchWiki for more info), then grab the archlabs installer:

curl -fSL -o /usr/bin/installer
chmod +x /usr/bin/installer
pacman -Syy dialog

Then launch archlabs installer with:


Might be worth a short as I had no issues doing it this way with an installation yesterday



I’m getting the same error as reported by @gregO when installing via the iso on both my laptop as well as via VM on my desktop.

I’ve tried the suggestion by @carterjmike and required the following additional commands:

pacman -Syyu
pacman -S dialog

Proceeding with /usr/bin/installer launches the ArchLabs installer. I get to the menu options 1-10 (storage management, mount partitions, etc), and each option takes me to an Exit menu:

“Unmount partitions (if any) and exit the installer?”

Yes drops me back to the archiso root prompt, and No simply goes back to the exit menu.

Am I supposed to unmount anything? The main disk isn’t mounted so I’m not sure as to what I’m meant to unmount.

Sorry @carterjmike I missed a key instruction of yours “latest archlinux iso” :slight_smile: I was using one from September last year. Now using one from 1st Jan 2022 and the ArchLabs installer is now working for the VM. I’ll try my laptop later once the install for the VM finishes.

1 Like

Ah completely forgot about needing to install dialog before running the installer. Thanks for reminding me (updated my original message). Glad the install worked…good luck with the install on the laptop!

Thnx @carterjmike , a great interim solution. Works like a charm indeed.

this absolutely worked carter!!. thanks for helping out. this worked great on my VM i will still want to test it out a bit and play around with it before i put it on my laptop.

1 Like

Mmmm, well this is indeed a nice, though a bit elaborate, solution. But kudo’s anyway. And it works. What we seem to have lost: what was the actual cause of the issue?