ArchLabs 2020.05.04 is Available for Release

Today, on this day of Star Wars celebration we are happy to announce the release of ArchLabs 2020.05.04.

Not a lot of changes but you can view the changes at the Release Notes page.

@dimaom is an official ArchLabs team member had has made his presence felt in the Slack chats :smiley: Very talented dude to have alongside our @natemaia.

As per usual, any issues will need to be posted in the appropriate categories please.

Thank you for all your support. Its been a busy few months with the website move, forum move and the new release.

Some nice solid feedback from those who tested. It’s just what we like.

Thanks again and Enjoy. Please spread the word on social media, and any Linux related sites :smiley:

Get on it!

Matt, Nate, Dima and the ArchLabs Team.
May the Fourth Be With You

or in the words of his greatness, Chewbacca “rooooooarrrrguuggggghhh”

19 Likes

Thanks team!

1 Like

Top again @Dobbie03 @natemaia

Welcome @dimaom as a team member.

Thx for the hard work in there.

1 Like

Hello Great Team,
good job, i download and install it.

Best regards
Naltap

1 Like

Congratulations on the new release! :tada: :confetti_ball:

To be honest, I haven’t given it a spin yet, will do that later this day.

2 Likes

Thanks again for the best team!! :muscle: :muscle: :muscle: :muscle: :muscle: :mechanical_arm: :mechanical_arm: :mechanical_arm: :mechanical_arm:

2 Likes

I am unable to complete an install I get incomplete chrun messages at at least two steps:

Install of the display manager: I tried sddm & lightdm The lightdm message (not error0 reads:
chrun 'pacman -S lightdm lightdm-gtk-greeter lightdm-greeter-gtk-settings accountsservice bash intel-ucode linux --noconfirm --needed'

When attempting an install using SDDM I get a similar sddm message.

On the sddm install I received an seconf install message (abend)
chrun 'mkinitcpio -p linux'

So for me the installer is broken… :frowning: @natemaia @Dobbie03

Here’s my machine particulars run from my MX partition:

$ inxi -Fxxxz
System:
  Host: mx19-ahs Kernel: 5.4.0-3-amd64 x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.26.0 Distro: MX-19.1_ahs_x64 patito feo February 15  2019 
  base: Debian GNU/Linux 10 (buster) 
Machine:
  Type: Laptop System: Dell product: Inspiron 5493 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0M4FW1 v: A00 serial: <filter> UEFI: Dell v: 1.8.0 
  date: 03/24/2020 
Battery:
  ID-1: BAT0 charge: 39.9 Wh condition: 39.9/42.0 Wh (95%) volts: 13.1/11.4 
  model: BYD DELL 1VX1H9A type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP 
  arch: Ice Lake rev: 5 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19046 
  Speed: 668 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 743 2: 667 
  3: 709 4: 916 5: 914 6: 652 7: 646 8: 903 
Graphics:
  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:8a56 
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
  compositor: compton v: 0.1~beta2+20150922 resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (Ice Lake 4x8 GT1) 
  v: 4.6 Mesa 19.3.3 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:34c8 
  Sound Server: ALSA v: k5.4.0-3-amd64 
Network:
  Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet 
  vendor: Dell RTL810xE driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 
  chip ID: 10ec:8136 
  IF: eth0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 168c:0042 
  IF: wlan0 state: up mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:6 
  chip ID: 0cf3:e009 
Drives:
  Local Storage: total: 983.96 GiB used: 551.42 GiB (56.0%) 
  ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD 
  size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: ECFM22.5 
  scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Generic model: SD MMC MS PRO 
  size: 30.09 GiB serial: <filter> rev: 1.00 scheme: MBR 
Partition:
  ID-1: / size: 59.69 GiB used: 10.04 GiB (16.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 64.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 236 Uptime: 6m Memory: 23.33 GiB used: 1.29 GiB (5.5%) 
  Init: SysVinit v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 
  Shell: bash v: 5.0.3 running in: sakura inxi: 3.0.36

And now on linux tracker
Linux Tracker
seeding now :wink:

3 Likes

Top @Naltap

1 Like

We can only test an verify so much, none of our installs had problems like this so I’m not sure, something with the network or mirrors maybe. These also seems to be the same errors you’re getting with the beta isos.

When you have this happen, wait at the error message and do this:

First Ctrl-z to pause the installer and return to shell

tput cnorm  # restore terminal cursor

Now you’re in a shell with the installed system on /mnt
If the error is chrun .. that means it’s running on the installed system in chroot, so do this

arch-chroot /mnt

# now run the error command and see what happens
pacman -S lightdm lightdm-gtk-greeter lightdm-greeter-gtk-settings accountsservice bash intel-ucode linux --noconfirm --needed

What kind of errors do you get?

After you’re done

exit   # exit the chroot
fg     # resume the installer

Great Job guys!

Hi everyone, just joined the forum because this is my first error during setup with archlabs, I have been using since the first “minimo” was introduced…
Anyway, I got the same error:

On the sddm install I received an seconf install message (abend)
chrun 'mkinitcpio -p linux'

I selected the " install from ISO", luks and lightdm
After the install finished system wouldn’t boot with errors like:
“Warning: /lib/modules/5.6.8-arch1-1/modules.devname not found - ignoring”
“mount: /new_root: no filesystem type specified”
and some other errors…

Hope you guys fix this!
Thanks for developing archalabs!

seeding it now.

Yeah I thought it was a good idea to have an alternative to direct download, so didn’t think twice and I uploaded it to linuxtracker .

Didn’t try an install through a VM yet but I will, anyway GG for the 2020’s release :wink:

It throws no errors…aside from there being a message saying there are no error messages. @natemaia
The installs just fall into some ‘bit bucket’,

I think it has something to do with the Dell Intel i5-gen10 chipset. I updated the bios as of 15 April 2020 ( the latest release).

I don’t see an option to edit my post above…
I tried again, same error during installation:

"Command: chrun ‘mkinitcpio -p linux’

Error:
no error message found

Errors at this stage must be fixed before the install can continue.
blah blah …
"

1 Like

@spsf64 Can you place the results of

inxi -Fxxxz using the little </> to make the data more readable here in a comment. It may make it easier for us to find similarities. I’m guessing we fall through every error trap… wahoo we’re special! :wink:

@manyroads I will have to compile inxi, don’t have it here…
But I tried in virtualbox and bare metal, same error.
I think there is something related to kernel, because during install I can see kernel 5.6.10 being downloaded and the error msg is about kernel 5.6.8… (see my first post)

ps. where is the edit option in this forum???

Hope @natemaia hops in to clarify whats is going on with the installer…

Gee, I need an option to edit my posts! lol!