Arch install fails on "grub ... --target-i386-pc" , and boots into a grub prompt

hello everyone this is my first archlabs install error post!

so after 2x attempts at installing archlabs on a thinkpad t410 ( legacy boot) on a free partition to achieve a dual boot with windows 10, I ended up with some errors-

ERROR: installing for the i386-pc platform
Installation finished. No error reported
Unrecognized option --target=i386-pc

grub-mkconfig -o /boot/grub/grub.cfg fails with-

failed to get canonical path of airrootfs

cant arch-chroot mnt either, and that returns with-

mount/proc mount point does not exist

the device boots into a grub prompt-
and loading a winPE environment it cant see the OS if you probe with bootrec /ScanOs

However- a os-probe does detect the windows and archlabs partitions sucessfully.

any help is appreciated.
Lastly sorry about the grammar i had to type that all out im on another machine atm.

Best

-R

some of my references which i didnt include in the first post-


Can t help you much but have a look @ this link, unless you already did: for now, some might chim in & give you a hand.

Please Have A Look at These Links Before Installing AL General ArchLabs Discussion

As stated in title , check the changelog before installing, there s some usefull info in there:https://archlabs.github.io/ As well as this link:

Thinking about it, wonder if it has anything to do with i386 platform somehow.

this might be a dumb question but- am i stuck with grub in this instance because of the dual boot scenario?

Don t think so, some members here have multiple installs.

^ This indicates that you haven’t chrooted in to the installed system and are still running from the “live” environment.

If arch-chroot doesn’t work can you do it manually?

If the main system partition is on /dev/sda3 (for example) then use

mount /dev/sda3 /mnt
for i in proc sys dev ; do mount --rbind /$i /mnt/$i ; done
chroot /mnt /bin/bash
grub-install --target=i386-pc --recheck /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
exit
reboot

If you have /boot on a separate partition then mount that (to /mnt/boot) as well before running the chroot command.

thanks for the heads up, ill try when i get a minute by the machine :slight_smile:

i had this error, i just tried again and no problems since

What was your solution if you remember it @lemler3

Glad that you fixed it.

ok a mount /dev/sda1 /mnt-

Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted or another software may use it which could be identified for example by the help of the ‘fuser’ command.

ill try a reboot,then back into live and see what else comes up.

i was trying to take a photo of the errors before i rebooted-

Is the ArchLabs system not fully installed then?

I take it you can boot into Windows now?

If you wait a bit then somebody more familiar with the mechanics of the ArchLabs installer may be able to help more.

Sorry, but you explain why install a grub for architecture 32 instead of 64?

Please post computer specs @ op, might help .

The --target=i386-pc is for non-UEFI systems and does not mean 32bit.

1 Like

For wiki arch linux grub

First, install the packages grub and efibootmgr: GRUB is the bootloader while efibootmgr is used by the GRUB installation script to write boot entries to NVRAM.

Then follow the below steps to install GRUB:

    Mount the EFI system partition and in the remainder of this section, substitute esp with its mount point.
    Choose a bootloader identifier, here named GRUB. A directory of that name will be created in esp/EFI/ to store the EFI binary and this is the name that will appear in the UEFI boot menu to identify the GRUB boot entry.
    Execute the following command to install the GRUB EFI application grubx64.efi to esp/EFI/GRUB/ and install its modules to /boot/grub/x86_64-efi/.

# grub-install --target=x86_64-efi --efi-directory=esp --bootloader-id=GRUB

That is for UEFI systems, which the OP does not have.

thinkpad T410 -
intel i5 M 520 @ 2.4 ghz dual core
4 gb ram
300 Gb ish hard drive
Bios Boot

its an oldie.

Sorry.
Are we sure you use windows10 without uefi?
thank