Antergos > Arch > Archlabs: in search to convert to Archlabs

Antergos user in search how to convert to Arch and then to Archlabs without new install. I have a MacBook Pro running Antergos for a long time, but as you know Antergos has stopped and I missed the explanation how to convert to Arch. Antergos website is gone.

Searched the web but all I find brings me to the archived not properly working Antergos website and forum. Because I have already used Archlabs somewhere in the beginning I want to make the switch back.

How to go from Antergos to pure Arch and then to Archlabs with an already working Antergos installation?

Tried a new Archlabs install on my 2008 MacBook Pro but the AL installer can’t get connected to the internet while I know what I have to do. Plus I want to keep my already for a long time working installation and settings.


I don’t know the specific of how antergos operated, but my first suggestion is to remove antergos repos from /etc/pacman.conf then update and remove any packages that throw errors for missing using pacman -Rncs.

After that you should be down to to a somewhat usable base.

As for the conversion to AL, you can add our repos to the pacman conf and install the packages you want. Customization and configs won’t be propagated for your user though, you’ll have to do that manually by copying from /etc/skel to your home directory.

Let me know how it goes.

1 Like

What do you mean here? The installer doesn’t connect to the internet, it checks if it can get a response from the arch package repos required and if not it opens nm-cli (assumed WiFi) once that has exited it checks the repos again.

If you connect yourself before running the installer you should be fine.

Older Macbooks are almost always a problem, we don’t do anything to help with this and you’re expected to load and unload kernel modules required to get WiFi up and running. I suspect your WiFi chip is one of the broadcom ones that require specific firmware. Check the arch wiki page for broadcom, find what chip yours is and what module it needs to work.

1 Like


Update was going well till the internet was down for a long time. Pity!
I got this error when trying to start the update again when internet was back:

pacman: error while loading shared libraries: connot open shared object file

Tried some solution on Arch forum but nothing helps.
Done a restart, now I don’t get to the login screen anymore.

Sad, the partly update has broken the installation that was working for many years.

Some ideas?
I have the latest Archlabs iso on a live USBkey ready and working.

Can I fix and do the update further from the latest Archlabs iso on a live USBkey?

Yes you just have to mount the partitions and arch-chroot into the install, if it’s really broken then you can re pacstrap it (both from live USB). There’s plenty of posts on the forum from me on how to do this:

Just mind that if the chroot fails you will have resort to pacstrapping it first. If your stuck then I can walk you through it.


No internet with the live USB installer?
ping -c

Temporary failure in name resolution

Using Ethernet cable and second computer to test, internet works.

Does running nm-cli not show any networks available?

What modules are running


What is your WiFi device

lspci | grep -i 'eth\|wl\|wifi\|net' 

There’s surely an easier way with less regex I just can’t remember and on the phone

This is generally the way to go, then you can figure out the wireless issues from a Gui. Macbook from around that era are known to be problematic in other os, so fingers crossed for you

I use Ethernet cable because of the known problems with the Wifi Broadcom Inc. chip.

lspci gives:

00:0a.0 Ethernet controller: NVIDIA Corporation MCP79 Ethernet (rev b1)
04:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

Ethernet and Wifi was working under Antergos installation.

Maybe if this is too complicated to do now:
Can you help me out to put an fsarchiver backup back from the Archlabs live USB?
So I can restart with my previous Antergos and try the all update and converting again.
… no fsarchiver in the Archlabs installer, so I will need internet working.

Do I understand well that you are helping me from your phone?
If that’s thru, you don’t have to do that.
This weekend I will make an old Antergos live USB, boot from that one, put the fsarchiver backup back, boot into the previous Antergos installation and restart the update and conversion from Antergos to Archlabs. Then I will come back to let you know.

Seems your chip is supported by the b43 firmware. While it is on free and normally in the AUR we have it included with our repo and it should be installed already, you will just have to load the needed modules, see


Yea the work day is almost over then I’ll be at a pc.

Yes, now I remember, that’s the one I have installed years ago in Antergos.
But will the b43 firmware also fix the Ethernet?
That’s a lot faster for updates then the slow wifi here.

Thanks for all your help already!

But for me (Belgium) it’s becoming late, so one of coming days I will try this:

Make an old Antergos live USB, boot from that one, put the fsarchiver backup back, boot into the previous Antergos installation and restart the update and conversion from Antergos to Archlabs.

Then I will come back to let you know or if I need help to get AL running.


It’s working i am now in between Arch and Archlabs. :wink:
All info found on this and the Arch wiki/forum.

To get again used to Archlabs, I start only with Openbox and Polybar and I wanna config all the same as the standard Archlabs Openbox install. When that’s working I will start config to my needs. I am almost there, but:

  • Is there somewhere a list with all needed applications from the standard Archlabs install so I can check all is there?
  • And how to activate Rofi? (searched like crazy to get that working)
  • Where could I config Rofi that it starts when I use the cmd+space keys?
  • Where do I find the standard Archlabs Polybar configs?


You can get the default package list by searching the installer
Most of what I’ll offer will be current (may not work without access to our unstable repo). You will also need our keyring installed or disable verification for our repos in your pacman.conf.

# base install
BASE_PKGS="base xorg xorg-drivers sudo git gvfs gtk3 libmad libmatroska tumbler "
BASE_PKGS+="playerctl pulseaudio pulseaudio-alsa pavucontrol pamixer scrot xdg-user-dirs "
BASE_PKGS+="ffmpeg gstreamer gst-libav gst-plugins-base gst-plugins-good bash-completion xterm"

# installed when a user selects any of the available WM/DE
AL_BASE_PKGS="archlabs-keyring archlabs-icons archlabs-fonts archlabs-themes "
AL_BASE_PKGS+="archlabs-baph archlabs-wallpapers archlabs-scripts archlabs-skel-base"

# installed only for openbox, i3, xfce4, awesome, fluxbox, dwm, and bspwm  
WM_BASE_PKGS="arandr nitrogen polkit-gnome network-manager-applet "
WM_BASE_PKGS+="volumeicon xclip exo laptop-detect xdotool compton wmctrl feh "
WM_BASE_PKGS+="gnome-keyring dunst gsimplecal xfce4-power-manager xfce4-settings"

For openbox install all of it. You will also need the relevant skel packages: archlabs-skel-base and archlabs-skel-openbox which will pull in more required packages used by each WM (eg. obkey for openbox)

We use ksuperkey in combination with a keybind in the WM (Alt-F1 by default) to allow opening it with a single key. You can get the command from /etc/skel/.xprofile once the archlabs-skel-base package is installed, there is already all the stuff setup in our skel packages for this to work if ksuperkey is installed.

For the keybinds you would do that in your WM (~/.config/openbox/rc.xml for OB)

We’re moving away from including polybar for the future so I suggest installing the AUR package instead of our archlabs-polybar if you want to use it (the latter will eventually be removed from our repos). But you can get our default configs here (the scripts and configs folder).

I’m gonna skim over it because the polybar wiki covers all this stuff, but we also used a wrapper script al-polybar-session to load polybar and do some setup/dynamic module stuff. Without using this script you will have errors/oddities with our default configs.

When I talk about skel stuff please understand that you will have to copy files or specific bits from things in /etc/skel to your own home directory, they are not used otherwise. This is normally done for you when creating a new user with useradd etc.

Let me know if you run into any issues.

1 Like

Keyring and so on already done.
Checked the packages and most where there already, I have filled the gaps.
Archlabs-skel’s are in place.

Restart and then when I login computer goes shutdown? ;-(
It’s Lightdm or the display settings, I think.
Edit: Can login with standard user but desktop is empty, nothing there only mouse arrow, pure minimalist. :wink:
How can I get the terminal up and running out of nothing?
Can you help me out on this one?

1 Like

Sounds like you didn’t copy the skel configs to your users home directory cp -rfT /etc/skel $HOME, see the end paragraph or my above post.

If I’m wrong above, xterm is in that list of packages so you don’t end up without a terminal. Ctrl-Alt-F2 to use a different tty then you can login.

1 Like

I did copy the skel configs, so will try with xterm to get it running.
Too much work now, so will be silent for a while.

You installed both archlabs-skel-base and archlabs-skel-openbox before copying?

1 Like

Sorry for late answer; yes, I did install them before.

I can’t get around the problem.
Problem is this:

boot -> works
lightDM -> works but login screen is not visible, it’s somewhere on a invisible second display. I know that some Mac computers show only in Linux some ‘ghost’ second screen.
Sometimes I manage to login while without seeing the login screen doing all the needed steps that I know.
login in admin -> black screen and freeze
login in user -> complete empty openbox desktop

When you don’t have the time or aren’t tired of this let me know, than I restart all from my old Antergos backup.