Another problems with Time post

#1

Guys, sorry to beat a horse that really should be dead already but I’ve scoured the usual pages and even here in the forum where a couple of users had similar issues but the solutions presented haven’t been able to solve my problem.

I recently reinstalled with i3 and everything is butter smooth without any issues except for the sys time that just refuses to reflect what it says on every single check in the terminal (timedatectl status, date, hwclock, etc). So after so many tinkering I just want to know if there’s even a reason to find a “solution” because nothing has worked so far.

The timedatectl and date commands show the correct local 00:45 am, utc, timezone and rtc times and also all the sync options are active but still as you can see from my screenshot the time in polybar shows some weird approximation of UTC not my real time (America/Venezuela). I have ntp installed and timedatectl set-ntp true ran and I guess it’s almost close to be a nonissue because I haven’t received any “wrong time” messages from apps or sites.

Any help would be greatly appreciated, for reference I run AL Openbox and I’d never had to dig so much into time settings because I’d never had this happen with any distro I had run before (AL included)

Thanks in advance guys.

0 Likes

#2

Seems like a timezone issue

ls -lAh /etc/localtime

Is that a symlink to your timezone in /usr/share/zoneinfo?

Also, do you multi-boot with other systems that have different time settings?

2 Likes

#3

Hey, Nate

That command gives me this:

lrwxrwxrwx 1 root root 35 Apr 11 18:52 /etc/localtime -> /usr/share/zoneinfo/America/Caracas

Which is indeed my time zone. And no this pc is only running AL.

Thanks

0 Likes

#4

maybe i write a bullshit, but i would try to disable npt service, my clock works without it.

[don@don-pc ~]$ timedatectl 
               Local time: ven 2019-04-12 14:06:08 CEST
           Universal time: ven 2019-04-12 12:06:08 UTC
                 RTC time: ven 2019-04-12 12:06:08
                Time zone: Europe/Rome (CEST, +0200)
System clock synchronized: yes
              NTP service: inactive
          RTC in local TZ: no
[don@don-pc ~]$ 
0 Likes

#5

I’ve disabled NTP also but then the clock says that it doesn’t synchronize while the timedatectl reports it correct the one in polybar never updates. I’m running out of settings permutations :slight_smile:

0 Likes

#6

try
ntpd -qg
reboot
edit
Maybe take a look here if it doesn’t work
https://wiki.archlinux.org/index.php/System_time

0 Likes

#7

Based on your screenshot and what you’ve written, is it the clock module in polybar that is always displaying the wrong time?

Have you checked the polybar module?

Is the polybar clock always off by the same amount of time?

0 Likes

#8

I agree with @PackRat, seems like the issue is only related to the polybar module, could always just make a custom module that runs date +%R every few seconds, which is what the time module is supposed to do.

Could also be an issue with polybar package needing to be recompiled.

0 Likes

#9

Well yeah I guess it seems so because for example something like tty-clock displays the correct time, same for the lines in the terminal, etc. And like I mentioned I haven’t received any messages from wrong system time from like the last.fm scrobbler and the like.

Regarding the module is pretty much the stock one just changed the position on the bar, I’ll try on monday since my AL Openbox main pc here at home doesn’t have this problem.

Thanks for your input guys I’ll report back just in case someone has this pretty insignificant but totally OCD triggering “error” happen to them too.

0 Likes

#10

It’s just stuck on the time shown in the screenshot the weird part is that just after the install it runs fine then it updates to this nonsense and gets stuck there. It’s the stock clock module and like I mentioned below I’ll try Nate’s suggestion of using a custom clock module to see if that was all the big whoop about.

0 Likes

#11

You could try the default polybar and modules, and see if that clock works with that.
For example I with the radio script taken from busenlabs when I start a radio station the polybar no longer works including the clock.
Ps) And maybe I should ask born because this is the polybar

0 Likes

#12

This is a good idea, I wonder if one of the modules is locking up polybar.

0 Likes