AL Installer and NVIDIA Video Cards Issue

Will a Mod please move the relevant posts from the ArchLabs 2022.05.29 Release thread to here so my work on this issue isn’t lost? That thread has been closed, and for good reason. TIA

Latest attempt succeeded. Must have been a temporary mirror glitch.

Of late, Al leaves me with this for my older NVIDIA cards:

I’ve been testing a half dozen Arch installers and they all play nice with my NVIDIA cards but AL. Some driver AL pulls in borks my setup. My Radeon cards work.

The Quadro 2000 was a high-end professional graphics card, launched on December 24th, 2010.
The Quadro K2200 was a professional graphics card, launched on July 22nd, 2014
Quadro K620 sales started 22 July 2014

In fairness, it’s a little early to conclude the Wiki idea is off, if that’s what happened. I only just read the call for volunteers and am formulating a response. (Something like a walk through of the install process with scrots - which I’ve offered before.)

Please give it a little more time. I noticed some members seem to only read the forum a couple of times a week. As a realist, I agree few people will step up. But please give it another day or two. (or three)

1 Like

Thanks. Tried the other kernels.
I’m thinking the installer pulls in the bumblebee driver when my card needs the something390something*** version

“so 515 was only buggy because it was still in beta stage… now it is released as production ready… and should work again… for all cards”

If you need 390xx specifically you will need yay -S lib32-nvidia-390xx-utils nvidia-390xx-dkms nvidia-390xx-settings nvidia-390xx-utils Substitute yay for your helper of choice.

edit now that I think about it (not an nvidia guy) you could probably just roll with neuveau on the installation and install the driver you need after you successfully boot into the installed system.

I don’t get a usable install to install the correct driver. I can’t even get a TTY to see what driver is used.

The installer decides what driver to use. I tried commenting out that section of the installer, but it looks like I missed something.

1 Like

Well if that is the case then all that really needs to be done (in theory and I do not remember is this is present currently) are two options when you fire up the iso. One option for free drivers neuveau/amd and the other for non free nvidia.

Sorry for being obvious…did you “remove /etc/x11/xorg.conf.d/20-*.conf”?

Before or after the install. :wink:

Looks like tear free gets called with out the -t flag

install_main()
{
install_base
genfstab -U “$MNT” > “$MNT/etc/fstab” 2> “$ERR”
errshow 1 “genfstab -U ‘$MNT’ > ‘$MNT/etc/fstab’”
[[ -f $MNT/swapfile ]] && sed -i “s~${MNT}~~” “$MNT/etc/fstab”
install_packages
#install_tearfree ← appears to run even commented out, something else calls it?
install_mkinitcpio
install_bootldr
chrun “hwclock --systohc --utc” || chrun “hwclock --systohc --utc --directisa”
install_user
install_login

I think I found it:

Line 1901 [[ -e $MNT/etc/X11/xorg.conf.d/20-nvida.conf && -e $MNT/usr/bin/optirun ]] && groups+=’,bumblebee’

misspelled nvidia - - - - - - - - - - - - - - - - - - - - - - - - - ^
@natemaia.

2 Likes

Thanks @altman Well done.

This one is relevant to your issue isn’t it:

https://forum.archlabslinux.com/t/archlabs-2022-05-29-release/6500/105?u=packrat

2 Likes

Yes. There is a couple of other posts I would have moved, but I’m just happy something was done.

We’re working on it. Seems I can only delete, not move posts.

1 Like

No problem mate

Will check it out, thx @PackRat

The driver is still borked. The patch is out in free bsd land now wait for the arch peeps…

2 Likes

Indeed it does, it will remove a config that cause issues on virtual machines or if tearfree was enabled it will do that jazz, but doesn’t do anything else. If that call is commented out then it’s impossible it’s being run, nothing else calls it.

This is the jist of what happens in install_tearfree

if [[ $VIRT != 'none' ]]; then
		[[ -e "$MNT/etc/X11/xorg.conf.d/40-touchpad.conf" ]] && rm -fv "$MNT/etc/X11/xorg.conf.d/40-touchpad.conf"
elif [[ $TEARFREE ]]; then
     ...
fi

This will affect users of the tearfree flag but nothing else, for a “normal” install there will be the following installed for ALL systems (line 83)

"xorg-drivers" # TODO: should we only install specific drivers?

We don’t (yet) install specific drivers unless the tearfree option is used, in which case this and the specific driver will be installed.


I’ve fixed the typo you found thank you.

I think the best option is to pause the installer once finished (do not select finish and reboot) - use Ctrl-q and you’ll be dropped into a shell, the full installed system will be in /mnt so you can do

arch-chroot /mnt

and you’ll be in the system, from here you can see what driver(s) are installed and check the configs. I’d start with no proprietary drivers and remove any driver configs from /etc/X11/xorg.conf.d/, you can also manually install and configure things at this point.

2 Likes

It’s not, mirror selection is done within install_background, which is called once everything is mounted.
Without mirrors selected the background process would take too long installing the base meta package. It’s running while you pick user, system configuration, and the rest. It speeds up installs a considerable amount and is part of why the AL installer is fairly fast. With slow mirrors this process would lag behind and not be finished by the time you’re ready to “finish install”, leaving you with a message saying “A background install process is still running… tailing output”. That’s why it’s called “finish” to begin with, while you create a user and pick packages the mirrors are being ranked and the whole base is being installed. If you’re fast enough with the selections then even the whole WM/DE session will be done in the background while you finish.

Others have brought up this confusion as well as and language used (like “finish install”) but I don’t think it warrants a change.

I’m by no means against improving things and making it more clear what’s happening but I’m all out of ideas and this does the job correctly. If anyone has a better solution I’d be more than open to trying it out.

1 Like