ABIF installer help

Guys, is there a help page or some kind of walk through of the install process? I’m no noobie, but equally no linux guru. I have been through the process three times tonight and it keeps booting back to live user after I have been through the installer.

My guess is that Im messing up the partitioning. But thats all I have. However during the install archlabs base process there were a couple of errors telling me that the keyrings did not install.

??

Cheers

Do you see an errors during the actual partitioning part of the installation?

I don’t see how you could be booted back to the live user if you have partitioned without error and removed the install media. There is either ArchLabs on the partition or there is, well, nothing at all.

1 Like

There is no way the computer could boot into the live user if you have unplugged the live installer. My best guess is your BIOS has Live USB/CD above Notebook Hard Drive under Boot Device category. So after installing when you reboot without detaching the live installer it boots into the live user. After partitioning and installing you should shut down instead of reboot, remove the live installer and turn on your system again.

2 Likes

yes
http://landoflinux.com/linux_install_architect_linux.html

2 Likes

Agree with Pangolin. That’s sounds most likely.

1 Like

Hey @philT

Did you install the grub bootloader

After the main unpacking there are 2 main things that need to be done for it to boot

  1. Install grub
  2. Run mkinitcpio

These can both be found in the “Customize Installation” section

Hope this helps, just go through each option and complete it
The installer will jump you to the next option when returning to the menu so no need to remeber which option you’re on, this may cause problems if you skip a step thinking that you already did the one under the cursor, this isnt the case. Make sure to complete each step

Cheers

2 Likes

Thanks for sharing @ector

grub-mkconfig -o /dev/WHATEVERTHEpartitionisyouwantToBoot(/dev/sda etc) /boot/grub/grub.cfg …will do it run a couple of times as sometimes need to do that
Ben, in El Paso, TX

Ok, so I finally got AL installed. Thanks everyone.

However…

I accidentally closed the hello script and cant get it back (sorry for being such a spaz). Is there away to open it up again so I can run through all software etc…

@nate I thinking as I was rushing to install AL I missed the mkinnitcpio step.

All good now bar the hello script.

@philT Just go into the terminal and run al-hello to get the hello script back.

3 Likes

@philT, if this is solved for you, can you please mark which post was your solution using the solved tick box

Done. Cheers.

Looks like you can only tick one post as a solution.

Yup, only one solution can be selected. Maybe edit your first post with a mention if another post helped solve your isse.