[abandoned]Siduction-nox and dk

Hello people,

out of curiosity I installed siduction-nox in QEMU here to see how the dk window manager works in it (nox means the ISO comes without X).

All the requirements that @natemaia formulates ( libxcb-randr0-dev libxcb-util-dev libxcb-icccm4-dev libxcb-cursor-dev libxcb-keysyms1-dev sxhkd) are successfully installed. Now I’m up the creek because I do not know how to put the package dk in the installation.

I thought it was something like this:

git clone https://gitlab.com/teobigusgeekus/Accuweather_conky_script.git

but do not find an address.

Can anyone help me or is there a better idea. Thanks! :slightly_smiling_face:

git clone https://bitbucket.org/natemaia/dk.git
1 Like

From the README.md inside your git dk folder

You need the xcb headers

xcb-proto xcb-util xcb-util-wm xcb-util-cursor xcb-util-keysyms

To compile run


Edit config.h if needed, then run (as root if needed)

make install

If at any time you want to uninstall, run

make uninstall


To start dk you can add the following to your ~/.xinitrc

exec dk

Optionally copy the example dkrc and/or sxhkdrc to ~/.config/dk/

mkdir -p ~/.config/dk
cp /usr/local/share/doc/dk/dkrc ~/.config/dk/
cp /usr/local/share/doc/dk/sxhkdrc ~/.config/dk/

Yeah @knob, that worked flawlessly. The installaion of dk, with no errors. Big thanks to you!

@KoO, this is debian :wink:

Still I can’t get to the desktop.
Quasi I have installed ‘bypassing’ the package management. So I am missing any dependencies that are usually installed with openbox or fluxbox.
I have the feeling that a display manager is missing here…

1 Like

You don’t need a display manager. Is xorg-xinit installed?

I think I’ve encountered this error you are seeing. You need to do this as quoted from bitbucket. i.e copy the configs to ~/.config/dk. Ensure dkrc is executable


It will be build dependencies is (make) and (build-essential) installed. And the below.

Sorry I should have know better.
libxcb-randr0-dev libxcb-util-dev libxcb-icccm4-dev libxcb-cursor-dev libxcb-keysyms1-dev

1 Like

@knob, @KoO, thank you dear helpers.

I know the README guide from natemaia.

-the paths are created, dkrc is executable

-in debian the package is called xinit and was also installed by me as a precaution because I know the connection with the .xinitrc.

Now I have locked myself out of tinkering and ‘automatic login’ completely for now… :nauseated_face: :yum:

Well, I had to install myself a rescue live system in Qemu to overcome the auto-login lockout.
Luckily there are 3 partitions and not just one. Otherwise I would have had to redo dk.
I used steelhead from @cog for this, which worked flawlessly. Again I noticed how sparing @cog is with packages. Thanks again for that! :+1:

Besides dk I installed openbox. Only to find that I couldn’t get to the desktop with it either.
Ergo, I took the trouble to compare between stellhead and siduction and came up with the xorg package.

xorg is not installed in siduction-nox because there is a conflict with x11-utils. Installing x11-utils alone removes the package luit.

apt show luit
Package: luit
Version: 2.0.20221028-1
Priority: optional
Section: utils
Maintainer: Thomas E. Dickey <dickey@invisible-island.net>
Installed-Size: 136 kB
Provides: luit
Depends: libc6 (>= 2.34)
Breaks: x11-utils (<< 7.7+6)
Replaces: x11-utils (<< 7.7+6)
Homepage: http://invisible-island.net/luit/
Download-Size: 53,8 kB
APT-Sources: http://ftp.de.debian.org/debian unstable/main amd64 Packages
Description: locale and ISO 2022 support for Unicode terminals
 Luit is a filter that can be run between an arbitrary application and a
 UTF-8 terminal emulator.  It will convert application output  from  the
 locale's  encoding  into  UTF-8,  and convert terminal input from UTF-8
 into the locale's encoding.
 This is version 2.0 of luit, which can use encoding information from
 either the font-encoding data-files in the "xfonts-encodings" package,
 or the standard locale support in the C runtime library.

So I installed x11-utils and now I can get to the desktop. At least that’s what it looks like for now, but I don’t know if that’s actually the solution. :face_with_hand_over_mouth:

Example without startx, with lightdm:

Does your sources list include contrib and non-free.
To get x11 working on Debian all you need is below
xorg xserver-xorg xutils mesa-utils xinit

{for nvidia only nvidia-detect} run nvidia-detect then apt install nvidia-driver after driver installed reboot at the conflict screen.

Now install firmware
apt install firmware-linux-free firmware-linux-non-free

1 Like

@KoO, thank you.
That is unstable. :wink:

Actually, I already wanted to give up and press everything into the skat, because above that also did not work/not properly.
After a night sleep over it, I thought to myself that the order of installation of the window managers in this nox is wrong. :cowboy_hat_face:
So , I reinstalled again and first installed openbox and then did that with the dk.

Now it looks better. I still don’t have rofi though because it doesn’t find the rofi.sh. Likewise, I don’t have bar because I don’t know which is the easiest. Will maybe take ‘hatchery’ :wink:
However, the key commands ALT+Shift*Enter bring me the terminal. ALT+F; ALT+T; ALT+Q also works.

xrandr doesn’t exist and with arandr it doesn’t want to, we’ll see…

(I will get it right some day)
Is rofi installed on your system =yes then edit this line in sxhkdrc file.

# program launcher
alt + p
    rofi -show drun
alt + F1
    rofi -show drun
super + @space
    rofi -show drun
# launcher
alt + p
	rofi_run.sh <<< Home /.local/bin/rofi_run.sh this should be working fine here.

And yes xrandr is installed it comes with this package on Debian.

package = x11-xserver-utils

just keep or comment out these lines in your dkrc not needed.

commented out

# adjust border widths based on the DPI of the monitor
##px=$(xrandr | grep ' connected' | tail -n1 | grep -o '[0-9]\+x[0-9]\+' | cut -d'x' -f2)
##mm=$(xrandr | grep ' connected' | tail -n1 | grep -o '[0-9]\+mm' | tail -n1 | sed 's/mm//')
##dpi=$(( (px / mm) * 25 ))
##if [ $dpi -ge 140 ]; then
##        border_width=5
##        border_outer_width=3
##elif [ $dpi -ge 120 ]; then
##        border_width=4
##        border_outer_width=2
##        border_width=2
##        border_outer_width=1

#{ # compound command to redirect all output

Good tip with rofi, thanks for that.

Still, I have the impression that the interaction between desktop and the system does not work cleanly.

Look at the line spacing in the terminal and how the ascii looks ‘warped’.

You need to play around with the font setting.

Your better off asking the coders of dk I’m only a user.
natemaia archus or cog

I am giving up on this test in the VM with siduction.
It is now, as @Sector11 likes to say, above my pay grade.

On the one hand, this nox is already 1.2GB, without X(!), has lots of
packages that I don’t need. On the other hand, such simple things don’t work e.g. after installing openbox, that I in Thunar
and after a security prompt and entering the PW I am in the host. This does the little ‘hatchery’ without problems, without post-installing packages, immediately.

So I can’t safely rely on siduction as a base if I don’t know dk myself. The previous version of nox also kept me busy for days in another test, because the file system was ‘read-only’ after installation. Only, to find that the installer did not create an fstab.