404 error on pacman update

Updating pacman -Syu gives this error:

error: failed retrieving file 'archlabs_repo.db' from archlabs.github.io : The requested URL returned error: 404 archlabs_repo

and then it proceeds to update as normal.

What’s the fix?

I think it’s just a temporary error on your Internet connection. That’s why it then reloads the repository smoothly. Did it happen to you again?

1 Like

Happens every time since a week or two ago.

Wonder if it can be of any help here.

Edit, also have a look here;

1 Like

Update your pacman.conf to show

Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://sourceforge.net/projects/archlabs-repo/files/archlabs_repo/$arch

What is happening there is that pacman is attempting to update the archlabs packages via GitHub, as we have moved to BitBucket pacman is getting a 404. It is falling back to Sourceforge which is the alternative mirror.

The above is the new repo home.


Good call in there @Dobbie03


That fixed it. Thank you.

Cool, can you mark the thread solved please.

Glad that it got fixed there @gorki

@gorki don’t worry I’ll mark it solved. Cheers

1 Like

That fixed the problem Thank you!