2018.07 Testing Release


Another testing ISO

Please do an install, we want to test the installer further.

If you want to test, don’t do your standard install you would do for your everyday setup. Try something new.


@Dobbie03 Thanks downloading now…keep you posted. Would it be possible to number the testing releases sequentially?


@Dobbie03 How so, not to install our everyday setup ? You mean like trying an other partitionning, app install, DE and stuff like that ?


Edited & updated below.



That sux mate, hope it will get fixed soon ! Wonder what s happening with newer linuxes as a whole, maybe too many new hardwares, go figure.


I don’t know if this will help you but you could try my work around.

I was able to start x by deleting the xorg.conf.d directory.


Thanks Neil, I read your solution earlier. The iso boots on metal regarding my desktop but obviously something’s not right so, I’ll wait and see what the powers that be want to do. I really anticipate however, people having trouble with this version of the installer. The original testing iso in this series was a winner in my book, couldn’t make it fail.

Hope everyone’s doing well :slight_smile:


I had to do this too - delete the /etc/X11/xorg.conf.d directory contents in the live session.

Then went to install.

The installer recognized all drives/partitions but only allowed selection of a / partition to install the system. Then goes to completion.

After booting installed system, I had to once again delete the /etc/X11/xorg.conf.d contents (don’t need to remove the directory itself) to get to openbox.

Logged in as root and manually set up /home, swap, and other partitions.

Note - the installer uses the newer dynamic swapfile creation (see swap file entry in Arch Wiki for details) so no no need to create a swap partition prior to, or during, the install process. I partitioned the disk prior to running installer so reverted to old method afterwards.

Running openbox as regular user now.

Edit - I attempted to delete the contents of /etc/X11/xorg.conf.d one-by-one to see if only one of those files was causing issues. Had to delete them all in order to start openbox session.


st terminal still has the problem with ranger image previews…long story I think…
In my case an image preview will appear for a short time and then disappear.

Fired up Urxvt from the AL-hello script install time but need to tweak a bit;

URxvt*background: [95]#919ba0

changed to

URxvt*background: [95]#1C2023

URxvt.font: xft:DejaVu Sana Mono:size=10 (typo?)

changed to

URxvt.font: xft:DejaVu Sans Mono:size=11

Urxvt looking better and ranger image previews work without issue…


After having significant issues with latest testing iso, I downloaded the iso again and much of the issues are gone.

Able to boot into live system and install in both UEFI and Legacy mode. Issue with al-hello wanting network connected despite it being so, is gone. Ran through welcome script perfectly and everything seems to work nicely.

Lenovo Laptop;
Same live system issue as @PackRat & @mrneilypops in both UEFI & Legacy. Haven’t tried their solution as it seems moot to the point of the live iso but can if requested.

Acer Laptop;
Exact same results as my desktop.

**In case the issue comes up, both of these packages were included in first update after install



One or both of which killed pulseaudio on my system and have since added them to the Ignorepkg section of my pacman.conf until such a time I’m confident in them.

**No idea what the problem was earlier. Re-downloading solved polybar and odd al-hello issue and installer worked vastly different. Weird



Glad it worked on your installs. Might be because of corrupted iso that you had issues beforehand !


@altman I don’t know, could be but it may be pure user error. Wife’s still very ill and in hospital, so I’m not firing on all thrusters atm :slight_smile:


@Glenn , gee wondered what was happening with you mate !

Well I guess that Linux can be put aside for a little bit & it s understandable .

Hope that she ll get back on her feet quickly ! Say hello & get well soon from my part.


@altman Thank you, that means a great deal to me and I’ll make a point of passing that on to her :slight_smile:


@Glenn , thx, we might not know each other in real life doesn t mean that we can t help each other one way or the other right ! :smile:



@altman That’s right. Don’t have to shake hands to be friends and besides the awesome distribution, the ArchLabs community is what makes this all worth the while.


@Glenn , you bet mate !


Using the advice of @PackRat & @mrneilypops, I can confirm I was also able to reach x on my Lenovo laptop but needed to delete each file separately. For anyone interested…

@tty prompt

cd /etc/X11/xorg.conf.d

sudo rm 20-intel.conf

sudo rm 21-radeon.conf

sudo rm 22-amdgpu.conf





Thx, might be usefull to other members for future refs.


What partition scheme were you using for those installs?

I successfully booted to a live session on UEFI and BIOS laptops - don’t know what would be causing that error.