2018.07 Testing Release


#1

NOTE: I will update this post as more setups are tested, broken, and fixed.

Testing iso with mainly changes and bugfixes to the installer.

Google Drive Link

For those unable to access google drive please give me with a file sharing site that you can access, or wait for the upcoming stable release and get it from the usual sources

Since stable repo split there has been a fair few changes, the installer has gone from 1.4.12 -> 1.5.42 with 40+ commits, most of which were on the larger side. Over the course of the last week I’ve done a ton of installs, so the iso should be fairly battle tested by this point.

Below is a fairly comprehensive list of what works, what doesn’t, and what hasn’t been tested.
If you experience issues, please post a brief description of the steps taken during install like below.

Tested working

  • UEFI

    • Standard Ext4 for root / and fat32 EFI for boot /boot/efi using grub.
    • Standard Ext4 for root / and fat32 EFI for boot /boot using systemd-boot.
    • LUKS Ext4 for root / and fat32 EFI for boot /boot/efi using grub.
    • LUKS Ext4 for root / and fat32 EFI for boot /boot using systemd-boot.
    • LUKS->LVM Ext4 for root / and fat32 EFI for boot /boot/efi using grub.
    • LUKS->LVM Ext4 for root / and fat32 EFI for boot /boot using systemd-boot.
  • BIOS

    • Standard Ext4 for root / using grub.
    • Standard Ext4 for root / using syslinux installed to MBR.
    • LUKS Ext4 for root / and Ext4 for boot /boot using grub.
    • LUKS Ext4 for root / and Ext4 for boot /boot using syslinux installed to MBR.
    • LVM->LUKS Ext4 for root / using grub.

Tested Broken

  • FIXED Syslinux issue when booting new install
  • Issues with keyfile when using LUKS->LVM and grub. Requires entering password twice at boot.

Untested

  • LVM->LUKS on UEFI systems using either grub or systemd-boot.
  • More…

The installer has had a debug option for a while now, it’s fairly basic and can boiled down to four actions.

set -x
exec 3>| $LOG
BASH_XTRACEFD=3
st -e tail -f $LOG &

to enable it open a terminal and run

sudo /installer/installer [-d,--debug]

NOTE: It is recommended to update the installer first before running

pacman -S archlabs-installer

As always feedback, testing and help is welcome.

Cheers


Live ISO gets stuck
Openbox hangs on startup
Still getting errors when trying to install with CryptoDisk
WM/DE frozen when booting up USB Install and USB install failing
Dual booting with windows 7
Can't apply settings
Tried to reinstall AL, but
#2

@natemaia Thanks again, will have a go asap :slight_smile:


Archlabs won't boot after fresh install
#3

I’m hoping that this release will work. I could only install 2018.03 or older releases with my computer. But I have extra room to try this release and give it a spin. I always appreciate your work @natemaia and your knowledge of linux. Now about life…:grin:


#4

Great post @natemaia. Very detailed.

Just a reminder. For easy tracking please open a new thread in this category.
https://forum.archlabslinux.com/c/technical-issues-assistance/Forum-for-Feedback-on-Testing

I have opened it up to Trust Level 2 and above (previously Level 4 only).


#5

Awesome, will test and report back shortly. Kudos!


#6

@natemaia

Thx for the hard work here mate.


#7

You have done a wonderful job with this,thank you very much! :grin:
I had not had Archlabs installed for about a month,and was really missing it,my last install had serious problems with wifi,tried everything I could to fix it,but sadly nothing worked,still had “the network has been disconnected” … “the network has been connected” … “the network has been disconnected” … every few minutes,and had to give up,found afterwards it was network manager not liking any of the 3 wifi dongles I tried,Gnome and Kde networking worked perfectly,but sadly Archlabs had gone by the time I found that out.:disappointed_relieved:
Tried to Install Archlabs again,but had the frozen desktop problem with the current iso,tried the older ones,and had some very strange problems like “the program is not installed” on everything I clicked in the menu,al-hello not actually installing anything,the installer just freezing halfway through etc. tried all the usual things like different usb dongles,checking the iso’s were not corrupted but no luck.
But this has me happily using Archlabs once more,thank you very much again! :smiley:


#8

Burnt to iso, will check it out.


July 2018 Screenshot Thread
#9

Installed without issue today.
Love the installer! :heart_eyes:
Super speedy boot :sunglasses:
nvidia drivers installed no problem.

2018-07-07-153930_1920x1080_scrot.png

Have you considered including yay for AUR package management?
‘Yet another Yogurt - An AUR Helper written in Go’

EDIT: Do you think that xfce4-power-manager should be included by default? I missed it first time around on al-hello…minor point…just my 2 cents.

EDIT#2: I have shifted around my polybar modules because as soon as the cpu usage enters double figures there is an an annoying twitch in the bar…at least for me…I searched on the polybar wiki but have not found a solution to ‘space’ the module sufficiently…
My current layout is;

modules-left = jgmenu workspaces mpd
modules-center = window_switch clock
modules-right = coreuse memory pkg network volume

It would be great to eliminate the ‘twitch’ on coreuse…

Keep up the great work team!


#10

Nice install in the @mrneilypops


#11

Hey, good to hear.

yay

  • We opted for aurman, any reason for the preference? For us the latter just seemed like the ‘best’ (at least according to the arch wiki), I tried it out and it was fairly good, so we made the switch.

xfce4-power-manager:

  • Yea this might be a good idea, the reason is we have been trying to keep things minimal and not include things people may not use. It quickly becomes difficult determining where to draw the line, what should be included, and what is just something that could be installed post-installation.

Polybar:

  • I’ll swap the modules around as you have above.

#12

Congrats on job well done @natemaia


#13

I already have and can’t replicate the issue.

xfce4-power-manager: Seems to be an issue for people wanting to use tint2. Does al-hello indicate it can be run again at anytime? I know BL’s does but can’t remember off hand if the reminder is there in al-hello?

Perhaps an entry in menu to al-hello or a pipe offering to install necessary services most users would need using tint2?

Just a thought.


#14

@natemaia
Thanks for the comprehensive feedback.
I am no expert on AUR helpers but following the supposed `demise´ of yaourt I am impressed with yay and the similarity in function to yaourt…just a thought…cheers.


#15

Here is the FIX for the CPU ‘glitch’ between single digit and double digit usage.
From the polybar devs;

Use the min length setting: label = %percentage:3%% (if you just want to do only double digits, use 2 instead).


:sunglasses:

Still ROCKIN’ yay guys…
https://github.com/Jguer/yay

Hope this snippet helps :heart_eyes:


July 2018 Screenshot Thread
#16

@mrneilypops

Thx for the workaround mate.


#17

png


#18

@pippo

lol, nice one in there !

I appreciate Nate s work in here, I m not able to do the 10th of what some of AL s members can do with Linux , so I appreciate the work/efforts done .


#19

Actually lol’d at this one


#20

erhm, I don’t have access…