17 inch Macbook Pro ArchLabs Thread

I have a Macbook Pro 6,1 17" (Mid 2010) and it was working decently with ArchLabs for 2 years, but it was time for a fresh install. Below is my adventure in hopes that it will help others with cult of Mac hardware.

I used the 2020.05.04 ArchLabs install.

First, this particular install did not go well. I tried about 6 times with a number of different options. Finally, without LUKS and the help of the many posts on install issues here in the forum, I got it.

Key was-- Installing a number of things via command line. I kept getting an Error that there was no error. User @HaxNet wrote this which is how I finished the install.

And then, there are some issues with a filename which I found here in the forum.

Upon reboot startup was frozen at some errors around my ethernet/wifi adapter. I chose to use reFind as my boot manager and couldn’t figure out how to boot to a command line. Meh. I installed again but after typing all the packages to install by hand, I followed instructions to fix the wifi adapter I wrote before. Now, when I ran the command to check if it worked, it did not look as if it did. Upon restart, the laptop booted fine. Did I fix it? Or was something else unrelated screwed up the first time?

Next, I couldn’t seem to get packages to install now that I had the OS running. I had to first install binutils and base-devel. After that, I could build packages without errors about "strip library or binary and a failure occured in build().

My volume keys work. The keyboard brightness keys also function. I don’t seem to be able to use the screen brightness keys. So I will continue my adventure to install my previous apps and see if I can figure out the screen brightness (and sleep which was one of the things that broke after 2yrs of AL).

I have a pkglist.txt but I fear if I install it all I will be back to issues I had before. I think I’ll install the things I want from the txt file, rather than try to edit it. That’s tomorrow. I think it’s time for a break.

2 Likes

This sounds like frustrating journey. I’m glad you was able to make it work at least for some degree.

Are there special dedicated keys for brightness? Or you mean key shortcuts like fn+f10/f11?

Yeah, there are dedicated keys. It looks like I was running pommed before.

Before I play more with the keyboard backlight controls, I should probably prioritize the graphics card issue. This old beast has the dual pain in the a** Intel integrated graphics and the Nvidia GT330M. So I have to remember how I set that up before.

OK. I am just disabling the the graphic card switching and using the integrated intel gpu on this Mac. First I tried to disable it in the efi using this forum post.

Why?

  1. This is a secondary machine to the desktop.
  2. It’s old. (But, yes still kicking).
  3. Maybe less heat from this hot plate.
  4. This doesn’t affect me personally, but the link above has helped people when the Nvidia card has died.

It seems like I was unsuccessful. Looking into spoofing through rEFInd.

Now, I have to figure out how to fix suspend which broke sometime ago and I had hoped a clean install of ArchLabs would fix it. Also, I would love to get back to figuring out my brightness keys.

Yeah, I am just talking to myself at this point. I am trying to document the reinstall, but my heart is not with it. I am getting so bogged down in the tweaks.

Right now, I am here and typing with a display that works, but it seems to be doing software rendering and yet using the Nvidia gpu instead of intel. Maybe I should be happy it is working at all.

1 Like

That’s why I pinned this thread for you :smiley: Also to help other Macbook users.

1 Like

Re-evaluating the things I want, rather than the desire to get everything perfect. The macbook is functioning out of the box with AL. That’s great! I do not really care what gpu is running. The only thing that would be nice is to dissipate some heat by using the intel chip.

What’s more important is getting suspend working. Right now if I close the lid, black screen and keyboard is lit when I open it again. I’ve read some stuff in my gpu searches on the Arch wiki and forum. Now, I just have to find them again. :frowning:

Sorry for the rambling. I promise I will clean this thread up or post a definitive list of what worked when I get there.

Two observations:

  1. Suspend/screen issues (possibly hybrid gpu issue?)
    screen shut off and came back on when I pressed a key when on battery power. (Honestly, have yet to test when plugged in.) However, closing the lid results in no screen, but the keys are lit. And, I have to shut down the computer to use it again.

  2. All kinds of nope–
    Adding this to xorg.conf, ’ Option “RegistryDwords” “EnableBrightnessControl=1” ’ was said to help others with brightness controls on the keyboard. X failed to load and I got a blinking cursor when I tried the tutorial to add that line properly.

  3. As a result of the above dilemma, I learned to edit the rEFInd boot options in order to boot a console and delete that nasty cofig file I made. F2 for boot options. F2 again to edit the selected option. Then I added ‘systemd.unit=multi-user.target’ (I should probably add this in the refind.conf as a permanent option.

With the help of this post in the Mint forums and another post on the ask ubuntu I was able to convince the PCI Express Bridge to fire up the connection between the nvidia card and the screen. So by setting a value in the EFI shell, that works.

I have yet to download the nvidia drivers and road test it, however. I’ve been needing the laptop to finish some training. So I paused here.

Also, the script I duplicated from here isn’t functioning correctly using the shell and rEFInd. It does turn on the card, but it doesn’t reload rEFInd so that I can choose AL. Instead, it spits me out into the EFI shell again. I can call the startup .nsh I made that launches rEFInd and then choose AL. I am unsure what the deal is there?